Logging in/Logging out
Incident Report for Remind
Resolved
This incident has been resolved.
Posted Jan 17, 2017 - 16:08 PST
Investigating
We are currently experiencing slow speeds on chrome for those trying to log in and out on Remind. This is only an issue on web.
Posted Jan 17, 2017 - 16:05 PST