Site Slowdown 5/22
Incident Report for Remind
Resolved
This incident has been resolved.
Posted May 22, 2017 - 08:40 PDT
Investigating
Some users may experience slow load times specifically while using quick actions and creating new classes. Message sends and deliveries are still up and running.
Posted May 22, 2017 - 08:30 PDT