Remind Outage 4/20
Incident Report for Remind
Resolved
This incident has been resolved.
Posted Apr 20, 2017 - 14:21 PDT
Investigating
Users may have trouble logging in and sending messages on web. Mobile apps are working slowly.
Posted Apr 20, 2017 - 14:19 PDT