Announcement delays
Incident Report for Remind
Resolved
All messages are back to normal delivery speeds! So sorry for the trouble!
Posted Dec 14, 2016 - 13:19 PST
Investigating
We are currently experiencing delivery delays of up to 25 minutes for announcements. Messages that aren't sent to one of your classes will get through just fine. Apologies for the inconvenience! We're working to fix this as quickly as possible and will update here when it's resolved. Please email support@remindhq.com with any questions you may have.
Posted Dec 14, 2016 - 12:45 PST