Remind login incident
Incident Report for Remind
Resolved
We're back up and running! No messages were affected.
Posted Jun 13, 2017 - 09:14 PDT
Investigating
At the moment, it isn't possible to log into Remind.com on web. For the time being, we recommend using the app instead. If you don't already have the app, you can download it from http://rmd.me/a.

We're so sorry for the inconvenience! Thanks for bearing with us as we get the site back up and running for you as quickly as possible!
Posted Jun 13, 2017 - 09:06 PDT