Remind Login Issue 4/20
Incident Report for Remind
Resolved
This incident has been resolved.
Posted Apr 20, 2017 - 13:43 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 20, 2017 - 13:40 PDT
Investigating
Some users might have trouble logging in
Posted Apr 20, 2017 - 13:39 PDT