Messaging Degraded Performance
Incident Report for Remind
Resolved
Remind is back up and running! We apologize for any confusion and inconvenience caused.
Posted Mar 25, 2021 - 21:29 PDT
Identified
In some cases, you may not be able to message individuals. We have identified the root cause and are working on a fix.
Posted Mar 25, 2021 - 20:18 PDT
This incident affected: Messaging.