Remind Outage 1/30
Incident Report for Remind
Resolved
This incident has been resolved.
Posted Jan 30, 2018 - 11:33 PST
Identified
Remind is down, but we already know the cause and should be up and running very shortly!
Posted Jan 30, 2018 - 11:14 PST
This incident affected: Website and Mobile Apps and Text and Email Messages.