Remind Site Slowdown
Incident Report for Remind
Resolved
This incident has been resolved.
Posted 3 months ago. Aug 22, 2017 - 14:19 PDT
Investigating
Some users might find Remind is moving a little slowly due to high traffic! We're working on this and it should be back up to full speed shortly.
Posted 3 months ago. Aug 22, 2017 - 13:15 PDT