Remind Site Slowdown
Incident Report for Remind
Resolved
This incident has been resolved.
Posted almost 2 years ago. Aug 29, 2017 - 15:41 PDT
Investigating
Things are still a little slow!
Posted almost 2 years ago. Aug 29, 2017 - 11:58 PDT
Monitoring
Things are looking much better! Almost back up to full speed again.
Posted almost 2 years ago. Aug 29, 2017 - 11:33 PDT
Investigating
Some users will find slow load times due to high volume. If you've just logged in, keep refreshing and your classes will appear! We're working on getting it back up to speed.
Posted almost 2 years ago. Aug 29, 2017 - 11:19 PDT