Remind Message Delivery Errors

Incident Report for Remind

Resolved

This incident has been resolved.
Posted May 30, 2025 - 11:00 PDT

Investigating

We are investigating an issue impacting the delivery of text message sent by verified Remind organizations. Messages sent by Remind app or email are still delivering properly.

We will provide an update shortly. We apologize for the inconvenience caused!
Posted May 30, 2025 - 10:32 PDT
This incident affected: Text Messages (SMS).