Issues Accessing Remind on Web

Incident Report for Remind

Resolved

This incident has been resolved. Be sure to refresh your page if you continue to have issues.
Posted Jul 14, 2022 - 12:58 PDT

Investigating

Users reporting having issues accessing Remind on the Web platform. We are actively investigating and working to resolve the performance issues. Thank you for your patience
Posted Jul 14, 2022 - 11:57 PDT
This incident affected: Website.