Website and app slow down
Incident Report for Remind
Resolved
All Remind systems have returned to normal! Services should no longer be impacted. Our apologies for the inconvenience!
Posted Mar 13, 2020 - 08:35 PDT
Identified
We are experiencing a higher than normal volume of traffic causing our website and mobile apps to load slower than usual.
Posted Mar 13, 2020 - 07:29 PDT
This incident affected: Website, iOS App, and Android App.