Degraded Performance
Incident Report for Remind
Resolved
This incident has been resolved.
Posted Sep 03, 2020 - 12:28 PDT
Update
We have fully recovered. Thank you for your patience.
Posted Sep 03, 2020 - 12:25 PDT
Update
We are continuing to investigate this issue.
Posted Sep 03, 2020 - 12:11 PDT
Update
Update: We are currently experiencing issues logging in to Remind. We are actively investigating and working to resolve the performance issues. We will provide an update within 30 minutes if the problem is not resolved by then. Thank you for your patience
Posted Sep 03, 2020 - 12:10 PDT
Investigating
We are currently experiencing slower than usual loading times for our website, apps, and text messages. We are actively investigating and working to resolve the performance issues. We will provide an update within 30 minutes if the problem is not resolved by then. Thank you for your patience
Posted Sep 03, 2020 - 12:04 PDT
This incident affected: Website, Text Messages (SMS), iOS App, Android App, Email Messages, Voice Messages, Website and Mobile Apps, and Text and Email Messages.