Degraded Platform Performance
Incident Report for Remind
Resolved
This incident has been resolved.
Posted Aug 04, 2022 - 08:25 PDT
Identified
We are currently experiencing slower than usual loading times for our website chat responses and updates to classes. This is due to one of our service providers currently experiencing an incident. Our engineers are working closely with that team to get us fully back up and running as soon as possible. In the meantime, Remind is fully operational via our iOS and Android mobile apps as well as via text and email. Please contact us via rmd.me/help for support with these workarounds. Unfortunately, we don't have an exact timeframe yet for recovery on web. Our apologies for any inconvenience caused!
Posted Aug 04, 2022 - 08:13 PDT
This incident affected: Website and Messaging.