Tutors are being kicked out of sessions
Incident Report for Remind
Resolved
This incident has been resolved.
Posted Dec 13, 2023 - 19:01 PST
Investigating
We are currently investigating this issue.
Posted Dec 13, 2023 - 15:57 PST
This incident affected: Tutoring (Video, Support).