Remind Outage 8/8/18
Incident Report for Remind
Resolved
This incident has been resolved.
Posted 11 months ago. Aug 08, 2018 - 13:17 PDT
Monitoring
Remind users may see some timeouts. We have identified the issue and are implementing our fix now.
Posted 11 months ago. Aug 08, 2018 - 13:09 PDT
This incident affected: Website and Mobile Apps.