Degraded Performance
Incident Report for Remind
Resolved
We should be good to go now! So sorry for any inconvenience caused.
Posted Oct 09, 2020 - 06:55 PDT
Monitoring
Remind is back up! We're still going to watch the performance of our service closely and will update this page again when the incident is fully resolved.
Posted Oct 09, 2020 - 06:23 PDT
Investigating
We are currently experiencing slower than usual loading times for our website, apps, and text messages. We are actively investigating and working to resolve the performance issues. Thank you for your patience
Posted Oct 09, 2020 - 05:50 PDT
This incident affected: Voice Messages, Website and Mobile Apps, and Text and Email Messages.