Remind should how be error free but still potentially slow as we continue to rebalance capacity. We'll keep working to resolve the latency!
Posted Oct 20, 2025 - 12:29 PDT
Update
We're continuing to see signs of recovery, but elevated error rates will likely continue. Our team is still hard at work on this issue!
Posted Oct 20, 2025 - 10:49 PDT
Update
Our team is working hard to create capacity for our critical services. While our web & mobile app experience may still be degraded, our text and voice services are operational.
Posted Oct 20, 2025 - 09:19 PDT
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 08:41 PDT
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 08:40 PDT
Monitoring
AWS has implemented a fix, and we're monitoring for full recovery.
Posted Oct 20, 2025 - 08:21 PDT
Update
AWS is recovering. We will continue working on the remaining issues.
Posted Oct 20, 2025 - 08:19 PDT
Identified
The Remind experiencing system issues at this time due to a mass AWS outage this morning. Our team is diligently working to solve the problem.
Posted Oct 20, 2025 - 06:51 PDT
This incident affected: Website, Text Messages (SMS), iOS App, Android App, and Phone Calls.