Site Slowness
Incident Report for Remind
Resolved
Thank you for your patience with the site issues. The site's performance is back to normal as of 5:03pm PT today.
Posted Dec 10, 2019 - 17:06 PST
Identified
Remind is currently experiencing degraded performance on our website, mobile apps and text/email messages. We believe we have identified the root cause and are in the process of confirming. The performance issue started at approximately 4:22pm PT. The performance impacts most of Reminds features. Unfortunately there are no workarounds at this time. We will update this page every 30 minutes until the issue is fully resolved.
Posted Dec 10, 2019 - 16:55 PST
This incident affected: Website and Mobile Apps and Text and Email Messages.