Remind Errors
Incident Report for Remind
Resolved
We're back up and running! So sorry for any delays you may have experienced.
Posted Aug 11, 2020 - 11:58 PDT
Investigating
Remind is currently experiencing performance issues that may be causing errors and delays on our site and/or mobile apps. We are actively investigating and working to resolve the issues. We apologize for the inconvenience caused!
Posted Aug 11, 2020 - 11:37 PDT
This incident affected: Voice Messages, Website and Mobile Apps, and Text and Email Messages.