Slowdown 10/22
Incident Report for Remind
Resolved
This incident has been resolved.
Posted Oct 22, 2018 - 16:24 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 22, 2018 - 14:55 PDT
Investigating
Messages to large classes might take a few more minutes to send than usual
Posted Oct 22, 2018 - 13:59 PDT
This incident affected: Text and Email Messages.