Degraded Performance | People List
Incident Report for Remind
Resolved
We have confirmed that the People List views and additions are back to normal operation. Thanks for your patience!
Posted Aug 07, 2023 - 20:03 PDT
Monitoring
Our engineers implemented the fix for the delay in new users being available to your People List. We're monitoring this to completion as we process the backlog of People List updates for your organizations.

We'll update here once more when the backlog is clear. Thanks for your patience!
Posted Aug 07, 2023 - 17:36 PDT
Identified
Our engineers have identified the root cause of the People List not getting updated when new users are added. The team is working to resolve and release a fix for the delay.

We'll continue to update this page as data updates are available.
Posted Aug 07, 2023 - 14:30 PDT
Investigating
We are currently experiencing slowness in loading newly added users to your People List. This will affect folks who have been added to your organization or classes today. Existing users within your People List will continue to be available.

We'll continue to update this page as data updates are available.
Posted Aug 07, 2023 - 09:30 PDT
This incident affected: Website.