Remind Slowdown
Incident Report for Remind
Resolved
This incident has been resolved.
Posted over 1 year ago. Jan 17, 2018 - 14:34 PST
Investigating
Some Remind users will find the site is slow or might have some trouble logging in. We're working on getting you back up and running!
Posted over 1 year ago. Jan 17, 2018 - 12:59 PST
This incident affected: Website and Mobile Apps.