Remind Rostering & Data Processing Delays

Incident Report for Remind

Resolved

We identified and have implemented a fix for the issue. We have confirmed that the issue has been resolved.
Posted Jun 30, 2026 - 16:05 PDT

Update

We are continuing to investigate this issue.
Posted Jun 30, 2026 - 14:42 PDT

Investigating

We are investigating reports that some users are experiencing delays with rostering and data processing. We will provide an update shortly.
Posted Jun 30, 2026 - 14:40 PDT
This incident affected: Rostering.