Remind Slowdown 9/5
Incident Report for Remind
Resolved
This incident has been resolved.
Posted about 2 years ago. Sep 05, 2017 - 15:13 PDT
Investigating
Some users will find that viewing and uploading attachments may not work for the next couple minutes. This is due to high volume, we're working on fixing it. Keep refreshing!
Posted about 2 years ago. Sep 05, 2017 - 13:10 PDT