Degraded Performance
Incident Report for Remind
Resolved
This incident has been resolved.
Posted Aug 17, 2021 - 21:12 PDT
Identified
We are currently experiencing an issue with our search composer. We are actively investigating and working to resolve the performance issues. Thank you for your patience
Posted Aug 17, 2021 - 20:18 PDT
This incident affected: Website, iOS App, and Android App.