Remind Slowdown 8/28
Incident Report for Remind
Resolved
This incident has been resolved.
Posted Aug 28, 2018 - 15:53 PDT
Monitoring
Some Remind users may experience slowness
Posted Aug 28, 2018 - 15:41 PDT
This incident affected: Website and Mobile Apps and Text and Email Messages.