Degraded Performance
Incident Report for Remind
Resolved
We're back up and running! Our apologies for any inconvenience caused.
Posted Feb 05, 2021 - 11:55 PST
Update
We are continuing to investigate this issue.
Posted Feb 05, 2021 - 11:22 PST
Investigating
We are currently experiencing slower than usual message loading times for our website & apps. We are actively investigating and working to resolve the performance issues. Thank you for your patience!
Posted Feb 05, 2021 - 11:22 PST
This incident affected: Website and Mobile Apps.