Degraded Performance
Incident Report for Remind
Resolved
This incident has been resolved.
Posted Oct 12, 2021 - 12:42 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 12, 2021 - 11:59 PDT
Investigating
The ability to message a school or a class is currently degraded. We are actively investigating and working to resolve the performance issues. Thank you for your patience
Posted Oct 12, 2021 - 11:45 PDT
This incident affected: Website, iOS App, Android App, and Messaging.