Degraded Performance
Incident Report for Remind
Resolved
This issue has been resolved. Please refresh your browser and try again.
Posted Nov 12, 2020 - 17:09 PST
Update
We are continuing to work on a fix for this issue.
Posted Nov 12, 2020 - 17:08 PST
Identified
We are currently experiencing issues with sending messages from accounts on web. We have identified the issue and are currently working to resolve the performance issues. Thank you for your patience.
Posted Nov 12, 2020 - 16:42 PST
This incident affected: Website, Voice Messages, Website and Mobile Apps, and Text and Email Messages.