Remind Outage 9/20
Incident Report for Remind
Resolved
This incident has been resolved.
Posted over 1 year ago. Sep 20, 2017 - 14:12 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted over 1 year ago. Sep 20, 2017 - 14:11 PDT
Identified
Some Remind users might experience trouble logging in, others will find very slow loading times.
Posted over 1 year ago. Sep 20, 2017 - 14:08 PDT