Remind Slowness
Incident Report for Remind
Resolved
Remind is back up and running! Thanks for bearing with us.
Posted Mar 30, 2020 - 09:52 PDT
Investigating
Remind is being used in unprecedented numbers as schools and districts respond to COVID-19, which may be causing intermittent errors and slowness. We're working actively to stabilize our service and appreciate your patience if you experience any delays or other issues!
Posted Mar 30, 2020 - 08:29 PDT
This incident affected: Website, Text Messages (SMS), iOS App, Android App, Email Messages, Voice Messages, Website and Mobile Apps, and Text and Email Messages.