Degraded Performance | District Overview Tab

Incident Report for Remind

Resolved

Our data delivery for School level information on our District Overview tab has been resolved.
Posted Jan 26, 2023 - 06:59 PST

Identified

We are currently experiencing slower than usual data delivery times for the School level information on our District Overview tab. We are actively working to resolve the data delivery timing.

We'll continue to update this page as data updates are available.
Posted Jan 26, 2023 - 06:26 PST
This incident affected: Website.