Messaging delays and errors
Incident Report for Remind
Resolved
We're back up and running!
Posted Mar 16, 2020 - 21:23 PDT
Investigating
Remind is being used in unprecedented numbers as schools and districts respond to COVID-19, which may be causing delays and intermittent errors on the app and website. We're working actively to stabilize our service and appreciate your patience if you experience any slowness!
Posted Mar 16, 2020 - 08:18 PDT
This incident affected: Website, Text Messages (SMS), iOS App, Android App, Email Messages, Voice Messages, Website and Mobile Apps, and Text and Email Messages.