Degraded Platform Performance
Incident Report for Remind
Resolved
Remind is back up and running!
Posted Apr 17, 2020 - 08:24 PDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 17, 2020 - 07:59 PDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 17, 2020 - 07:46 PDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 17, 2020 - 07:43 PDT
Identified
The issue has been identified.
Posted Apr 17, 2020 - 07:41 PDT
Investigating
We are currently experiencing slower than usual loading times for our website, app, and text messages. We are actively investigating and working to resolve the performance issues.
Posted Apr 17, 2020 - 07:40 PDT
This incident affected: Website, Text Messages (SMS), iOS App, Android App, and Website and Mobile Apps.