Delayed Message Delivery
Incident Report for Remind
Resolved
This incident has been resolved.
Posted Nov 19, 2020 - 22:03 PST
Monitoring
Remind's providers alerted us this evening on November 19th at 8:45 PM Pacific that they were experiencing delays in delivering messages to some Remind participants.

A hard refresh will resolve this issue. Please reach out to Remind's support (via rmd.me/help) if you continue to experience any issues after refreshing
Posted Nov 19, 2020 - 20:03 PST
This incident affected: Website and Website and Mobile Apps.