Delayed Deliveries
Incident Report for Remind
Resolved
This incident has been resolved.
Posted Nov 12, 2019 - 14:13 PST
Investigating
Remind's providers alerted us early this morning they were experiencing delays in delivering text messages to some Remind participants.

Impacted messages were those that were sent or scheduled to send on Tuesday, November 12th between 4:00am PST to 10:24am PST.

The trouble was resolved this afternoon and Remind re-sent all impacted messages.
Posted Nov 12, 2019 - 09:56 PST
This incident affected: Text and Email Messages.