Remind Outage
Incident Report for Remind
Resolved
This incident has been resolved.
Posted Jul 19, 2022 - 16:51 PDT
Investigating
The Remind service is currently experiencing some downtime. We hope to be fully back up and running as soon as possible and apologize for the inconvenience!
Posted Jul 19, 2022 - 16:22 PDT
This incident affected: Website, Text Messages (SMS), iOS App, Android App, Email Messages, Phone Calls, Messaging, Rostering and Tutoring (Video, Support, Whiteboard).