Degraded Performance | Login Confirmation

Incident Report for Remind

Resolved

We have confirmed that login verification flows are back to normal operation. Thanks for your patience!
Posted May 30, 2023 - 08:08 PDT

Monitoring

We have implemented a change that should resolve the verification issues for our users. We'll continue monitoring the status to ensure success! Thanks for your patience.
Posted May 30, 2023 - 06:59 PDT

Investigating

Some users are experiencing failed login verifications when attempting to log in to Remind. Our Engineering Team is actively engaged and working to identify the root cause. We appreciate your patience while we find a path to resolution.
Posted May 30, 2023 - 06:38 PDT
This incident affected: Website.