Remind Site Slowdown 9/25
Incident Report for Remind
Resolved
This incident has been resolved.
Posted Sep 25, 2017 - 16:18 PDT
Investigating
Some Remind users might find slow load times/login times. This is due to heavy load and we're working to get everything back up to speed.
Posted Sep 25, 2017 - 13:10 PDT
This incident affected: Website and Mobile Apps and Text and Email Messages.