Web and app slowdown
Incident Report for Remind
Resolved
We're back up and running!
Posted Mar 13, 2020 - 14:21 PDT
Update
We are continuing to investigate this issue.
Posted Mar 13, 2020 - 13:49 PDT
Update
Remind is currently experiencing issues that will cause varying performance. We are actively looking into a fix!
Posted Mar 13, 2020 - 13:49 PDT
Investigating
We are experiencing a higher-than-normal volume of traffic causing our website and mobile apps to load more slowly than usual. We're working hard to improve Remind's performance!
Posted Mar 13, 2020 - 11:00 PDT
This incident affected: Website, Text Messages (SMS), iOS App, Android App, Email Messages, Voice Messages, Website and Mobile Apps, and Text and Email Messages.