Incorrect phishing error on web
Incident Report for Remind
Resolved
Files are working as expected!
Posted May 22, 2019 - 19:50 PDT
Investigating
Remind is currently experiencing an issue where attachments aren't going through if sent when you're logged into your account on a computer. Our app is fully operational, and it can be downloaded via rmd.me/a. Thanks for bearing with us, and our apologies for the inconvenience!
Posted May 22, 2019 - 17:24 PDT
This incident affected: Website and Mobile Apps.