Degraded Performance

Incident Report for Remind

Resolved

This incident has been resolved.
Posted Aug 31, 2022 - 17:22 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 31, 2022 - 15:26 PDT

Identified

We are currently experiencing slower than usual loading times for our website and apps. We are actively investigating and working to resolve the performance issues. Thank you for your patience
Posted Aug 31, 2022 - 14:35 PDT
This incident affected: Website, iOS App, and Android App.