Remind website is currently down
Incident Report for Remind
Resolved
Remind is back up and running! Apologies for the inconvenience!!
Posted 6 months ago. Dec 14, 2018 - 08:52 PST
Investigating
You may have trouble logging into your account on Remind.com or using your account. We'll continue to post updates here!
Posted 6 months ago. Dec 14, 2018 - 08:27 PST
This incident affected: Website and Mobile Apps.