Remind Slowdown 10/23
Incident Report for Remind
Resolved
This incident has been resolved.
Posted over 1 year ago. Oct 23, 2017 - 16:03 PDT
Investigating
Some users will experience slow speeds when logging in. We're working on fixing this, sorry for the inconvenience!
Posted over 1 year ago. Oct 23, 2017 - 13:09 PDT
This incident affected: Website and Mobile Apps.