Remind Slowdown
Incident Report for Remind
Resolved
This incident has been resolved.
Posted about 2 years ago. Aug 29, 2017 - 10:55 PDT
Investigating
Some Remind users might find the site slow upon login due to high traffic. Refresh and your classes will appear!
Posted about 2 years ago. Aug 29, 2017 - 10:49 PDT