Remind Errors
Incident Report for Remind
Resolved
We're back up and running and will put preventative measures in place. Thanks for bearing with us!
Posted Jan 08, 2021 - 10:41 PST
Identified
Remind is currently experiencing performance issues that may be causing errors on our site and/or mobile apps. We are actively investigating and working to resolve the issues. We apologize for the inconvenience caused!
Posted Jan 08, 2021 - 10:20 PST
This incident affected: Website and Mobile Apps.