Slowdown
Incident Report for Remind
Resolved
Remind is back up and running!
Posted Mar 23, 2020 - 11:30 PDT
Monitoring
The service is returning to a more stable state. We hope to be back up and running soon!
Posted Mar 23, 2020 - 10:31 PDT
Identified
We are testing a fix! We hope to be fully back up and running as quickly as possible.
Posted Mar 23, 2020 - 10:29 PDT
Investigating
Remind is being used in unprecedented numbers as schools and districts respond to COVID-19, which may be causing intermittent slowness. We're working actively to stabilize our service and appreciate your patience if you experience any delays!
Posted Mar 23, 2020 - 10:00 PDT
This incident affected: Website, Text Messages (SMS), iOS App, Android App, Email Messages, Voice Messages, Website and Mobile Apps, and Text and Email Messages.