Remind Site Slow/Down
Incident Report for Remind
Resolved
This incident has been resolved.
Posted over 1 year ago. Sep 25, 2017 - 12:54 PDT
Investigating
Some users will have trouble logging in and using the site. We're working to get it back up and running!
Posted over 1 year ago. Sep 25, 2017 - 12:38 PDT
This incident affected: Website and Mobile Apps and Text and Email Messages.